home
StrataCafe Forums
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 StrataCafe
 General Discussions
 OpenGL control in video cards
 Forum Locked  Topic Locked
 Printer Friendly
Author Previous Topic Topic Next Topic  

BlindXP
Infrequent Poster

7 Posts

Posted - 07/07/2006 :  13:28:04  Show Profile
Hi all. Since it seems that there are a couple of us having problems with video card drivers (if Strata crashes, remove your drivers then see if you can run Strata. Works for me every time). I wanted to test OpenGL settings to see if I could get anything to work. I can't find an accurate way to control the OpenGL settings, even using Coolbits. Has anyone found a good method for controlling OpenGL with Nvidia cards?

I'm using a PCI-express 7800GT. I've tried all the drivers both beta and WHQL from as early as my card is supported up to the latest, and I mean ALL of them. I've swapped from WinXPx64 to 32 bit Win XP and tried all the 32 bit drivers as well. I can't use the 77.77 drivers that seem to work for most people because my card is not supported that early.

Hopefully we can find a good solution to this problem and keep us all using Strata on our blessed PCs, especially when your only other option is an outdated G4

Brian Lawson
A Fountain of Information

USA
5217 Posts

Posted - 07/07/2006 :  15:23:56  Show Profile  Visit Brian Lawson's Homepage  Send Brian Lawson an AOL message
Other than the video card drivers the only thing I've found to help is to turn off any OpenGL Acceleration the card's drivers may offer.

Brian Lawson
Strata technical support
Go to Top of Page

BlindXP
Infrequent Poster

7 Posts

Posted - 07/07/2006 :  18:26:10  Show Profile
Hi Brian! I don't see any "acceleration" for OpenGL per-say, do we know what exactly it is we need to disable, or change? If not I'll go through all these 1 by 1 and hopefully find a cure.

Go to Top of Page

Brian Lawson
A Fountain of Information

USA
5217 Posts

Posted - 07/07/2006 :  19:15:48  Show Profile  Visit Brian Lawson's Homepage  Send Brian Lawson an AOL message
No, I don't know exactly. There are so many video cards out there I can't keep up with them all. On an ATI card that is what it is called,"OpenGL Acceleration". I'm sorry but you're going to have to experiment with different settings to find what works and what does not as I don't have access to one of the nVidia 7800GT cards.

Brian Lawson
Strata technical support
Go to Top of Page

BlindXP
Infrequent Poster

7 Posts

Posted - 07/10/2006 :  11:06:34  Show Profile
I'll let you know what I find out.
Go to Top of Page

BlindXP
Infrequent Poster

7 Posts

Posted - 07/14/2006 :  18:58:00  Show Profile
Ok, I went through each option one by one, then I tried out all sorts of combinations. Here's the fix for my PCI-E 7800GT.
Using the latest nvidia drivers (91.31 at the time I wrote this), you can use the new Nvidia control panel and turn off OpenGL threading. That's it. That's the fix. Everything works for me now!!! I couldn't find this option on the older drivers I tried. Hope I just didn't overlook them. Thanks Brian for pointing me in the right direction with the OpenGL acceleration tip!



Hope this helps anyone else having this problem. Post here if anyone has any questions.

Edited by - BlindXP on 07/14/2006 19:01:01
Go to Top of Page

Brian Lawson
A Fountain of Information

USA
5217 Posts

Posted - 07/14/2006 :  21:18:23  Show Profile  Visit Brian Lawson's Homepage  Send Brian Lawson an AOL message
Thank you sir (ma'am?). I appreciate your help in finding the solution and letting us know about it.

Brian Lawson
Strata technical support
Go to Top of Page

JSantangelo
Infrequent Poster

USA
2 Posts

Posted - 07/17/2006 :  19:12:25  Show Profile  Visit JSantangelo's Homepage
Hi all- I've had the same problems with my card as well... I will check it out tonight to see if this also works for me. For anyone interested in what exactly OpenGL threading is:
(taken from tweakguides.com)

"OpenGL Threading: This option appears to control the use of multithreading optimization for OpenGL games on Dual Core/HyperThreading systems. The available settings are Auto, On and Off. I would strongly recommend the default option of Auto, allowing the drivers to set this appropriately for various games based on your hardware. However if you are running an OpenGL game (e.g. Doom 3, Quake 4 or Prey) on a dual core/HT system and experiencing problems, you can force this to Off for troubleshooting purposes."

I think you should also be able to have it only turn off for Strata so it can stay on "auto" for all other programs if you adjust it under "Program Settings" and not "Global Settings."

-John Santangelo
Creative Director,
Skyline Exhibits of Las Vegas
Go to Top of Page

Brian Lawson
A Fountain of Information

USA
5217 Posts

Posted - 07/17/2006 :  19:24:34  Show Profile  Visit Brian Lawson's Homepage  Send Brian Lawson an AOL message
Thanks John, that fits right in with what we've found about OpenGL acceleration (under what ever name the particular card vendor has given it) for increasing video game performance causing problems for Strata's use of the card. Performance for gaming is not the same as performance for modeling and the two sometimes come into conflict.

Brian Lawson
Strata technical support
Go to Top of Page

JSantangelo
Infrequent Poster

USA
2 Posts

Posted - 07/17/2006 :  21:20:06  Show Profile  Visit JSantangelo's Homepage
Just got to test out that fix above for the 7-series nvidia cards. It works! Thanks to you for your help and that of BlindXP. It might be worthy to note that the option to turn off OpenGL threading can only be found in the most recent driver sets nvidia released that has the new nView desktop manager interface. The older interface (pre 91.31?) does not have that option available to change. And you can disable only for Strata under the program settings tab- just add Strata to the list of programs and then turn off the OpenGL threading and apply.
-John

-John Santangelo
Creative Director,
Skyline Exhibits of Las Vegas
Go to Top of Page

Brian Lawson
A Fountain of Information

USA
5217 Posts

Posted - 07/17/2006 :  22:47:39  Show Profile  Visit Brian Lawson's Homepage  Send Brian Lawson an AOL message
Yes, BlindXP noted that he was using the 91.31 version of the drivers and could not find that option in the earlier versions for his card either. Good to know it is working for the 7 series cards as well. Thanks again John.

Brian Lawson
Strata technical support
Go to Top of Page

cbaldwin2
Infrequent Poster

USA
3 Posts

Posted - 07/18/2006 :  06:41:54  Show Profile
I have read through this thread and tried the various solutions with no luck. I found that by going into the trouble shooting tab under advance seddings that I could turn off all hardware acceleration. For me, this works.
Go to Top of Page

Brian Lawson
A Fountain of Information

USA
5217 Posts

Posted - 07/18/2006 :  09:03:08  Show Profile  Visit Brian Lawson's Homepage  Send Brian Lawson an AOL message
Which video card do you have Chaldwin2?

Brian Lawson
Strata technical support
Go to Top of Page

cbaldwin2
Infrequent Poster

USA
3 Posts

Posted - 07/18/2006 :  11:29:56  Show Profile
I have a PCI express 7900gt. I also have the 91.31 driver set, but there is no open gl threading option. If it helps any

Intel 945pcs motherboard
Intel D930 cpu
2 gig pc6400 mem.
Go to Top of Page

Brian Lawson
A Fountain of Information

USA
5217 Posts

Posted - 07/18/2006 :  12:48:35  Show Profile  Visit Brian Lawson's Homepage  Send Brian Lawson an AOL message
I don't have access to any of those cards so it doesn't help me but hopefully it will help other users with the same card. Thanks.

Brian Lawson
Strata technical support
Go to Top of Page

cbaldwin2
Infrequent Poster

USA
3 Posts

Posted - 07/18/2006 :  17:47:48  Show Profile
Brian, one other thing I do not understand.
As well as CX4, I have a 3DPro disk. When I could not even get the first screen where you have to input your serial #, I tried the 3DPro and have no problem with it. Any ideas.
Go to Top of Page

Brian Lawson
A Fountain of Information

USA
5217 Posts

Posted - 07/18/2006 :  17:52:09  Show Profile  Visit Brian Lawson's Homepage  Send Brian Lawson an AOL message
Starting with CX 4.0 the program was written to take better advantage of the onboard OpenGL processor on the video cards so there would be less work for the main CPU when displaying the various windows and palettes in the program. 3Dpro doesn't use the video card's processor the same way so it isn't sensitive to the card's settings in the same way CX is.

Brian Lawson
Strata technical support
Go to Top of Page
  Previous Topic Topic Next Topic  
 Forum Locked  Topic Locked
 Printer Friendly
Jump To:
StrataCafe Forums © 2009 StrataCafe Go To Top Of Page
Snitz Forums 2000