home
StrataCafe Forums
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 StrataCafe
 Strata Design 3D CX
 Step Files, WRLs from Solidworks into Strata
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Brett
Inquisitive

New Zealand
53 Posts

Posted - 11/08/2011 :  23:09:16  Show Profile  Reply with Quote
We have a client who has a lot of taps which are already created in Solidworks. Reading over a previous post about IGES importing, I purchased ViaCad which is opening up a supplied STEP file and showing a pretty good preview of the tap. However, the conversion to obj or VRML1 or 2 to get it into Strata shows up a few issues with the mesh. In the IGES post there's discussion about tesselation within ViaCad before export, is this something which could improve this file, and if so, how can I do this? The picture shows a preview of the tap in ViaCad, and a render from Strata with auto smoothing disabled. It gets bad where the two pipes meet. Thanks for your help.

Brett

Brett
Inquisitive

New Zealand
53 Posts

Posted - 11/08/2011 :  23:13:10  Show Profile  Reply with Quote
And here's the image.

Image Insert:

81.48 KB

Brett
Go to Top of Page

MrChristopher
A Fountain of Information

USA
2220 Posts

Posted - 11/08/2011 :  23:17:37  Show Profile  Send MrChristopher an AOL message  Reply with Quote
STEP is best because it maintains its solid nature, whereas IGES tends to come in as unconnected surfaces which requires extra work to deal with. In ViaCAD you'll need to tessellate the object and export that to Design3D as an OBJ or VRML 2 file. Jean Probert is the expert on ViaCAD usage here, but I will say that once you bring it over to Strata, it is important to turn off AutoSmoothing, otherwise the custom shading/normal information from the cad file will be thrown out resulting in a less than ideal appearance generally.

If you still see artifacts it is likely either a problem with the original geometry, or more likely the CAD data needs to be better tessellated in ViaCAD. This tessellation process, depending on the geometry, can take a bit of trial and error to get right.
Go to Top of Page

MrChristopher
A Fountain of Information

USA
2220 Posts

Posted - 11/08/2011 :  23:20:37  Show Profile  Send MrChristopher an AOL message  Reply with Quote
Ok, I think my hunch was right, that the tessellated geometry brought into Strata is not the best. You'll need to generate a higher res polygon mesh in ViaCAD then import that into Strata. These NURBS applications generate custom normal/shading info but it can't overcome polygon geometry that is too low res.
Go to Top of Page

jpro
A Fountain of Information

USA
4991 Posts

Posted - 11/08/2011 :  23:56:51  Show Profile  Visit jpro's Homepage  Reply with Quote
Definitely go with STEP over IGES whenever possible. IGES usually comes in all sliced into individual surfaces, which is very messy to deal with.

There's a secret handshake to getting higher resolution and quality meshes from ViaCAD. This will definitely work though, you just need to do another couple of things. It's late here now, I'll write this up a bit in the morning.

But for now, let me tell you to be sure and turn auto smoothing off after you import the mesh into Strata. That alone should make you current mesh render better. But I'll post a couple of screen shots in the morning with more info on getting a better mesh.

Brett, do you subscribe to the Strata 3D University site?

Jean

Edited by - jpro on 11/08/2011 23:58:29
Go to Top of Page

jpro
A Fountain of Information

USA
4991 Posts

Posted - 11/09/2011 :  00:18:00  Show Profile  Visit jpro's Homepage  Reply with Quote
Brett, reread your earlier post, and see that you did disable autosmooth. Could you send me your STEP file to look at? jpro2 at swbell dot net

Jean
Go to Top of Page

Brett
Inquisitive

New Zealand
53 Posts

Posted - 11/09/2011 :  15:02:42  Show Profile  Reply with Quote
Thanks Chris and Jean. I'm in New Zealand so our times cross over now and then. I'm sending you the STEP file now Jean. I do subscribe to Strata University.

Brett
Go to Top of Page

jpro
A Fountain of Information

USA
4991 Posts

Posted - 11/09/2011 :  15:17:56  Show Profile  Visit jpro's Homepage  Reply with Quote
great. Maybe I can use your file, or something similar, for a tutorial. I will assume you don't want me to use your file, since it is a customer file, and mock up something similar. If that assumption is incorrect, and I can use your file as an example in a tutorial, let me know.

Which version of ViaCAD are you using?

Jean
Go to Top of Page

Brett
Inquisitive

New Zealand
53 Posts

Posted - 11/09/2011 :  15:34:26  Show Profile  Reply with Quote
I'm emailing you Jean

Brett
Go to Top of Page

jpro
A Fountain of Information

USA
4991 Posts

Posted - 11/09/2011 :  18:01:52  Show Profile  Visit jpro's Homepage  Reply with Quote
Here's a quick run-down. When you export an object to a mesh format, the mesh resolution is determined by the object resolution set in the Inspector palette. The default is usually something like "very fine", but the mesh you showed earlier looks coarser than that typical default.

The defaults can be okay, but I don't generally use them.

You can create custom mesh settings if you export to STL format, which is what would typically be used for stereolithography. That will give you this dialog:

Image Insert:

35.87 KB

The image shows the parameters I set for your mesh. after you get this dialog up, you need to export the STL mesh that it creates. You don't need the STL mesh, but the only way to access this dialog is by exporting an STL. The mesh will now retain these settings, and you can follow up by exporting an OBJ or VRML2 mesh.

You can just throw the STL mesh away, it is not needed.

Jean

Edited by - jpro on 11/09/2011 18:03:24
Go to Top of Page

Brett
Inquisitive

New Zealand
53 Posts

Posted - 11/09/2011 :  18:14:26  Show Profile  Reply with Quote
This has been a great help, thank you very much. I had been playing with the resolutions in ViaCad which is why the mesh looked a bit coarser.

Brett
Go to Top of Page

jpro
A Fountain of Information

USA
4991 Posts

Posted - 11/09/2011 :  18:27:47  Show Profile  Visit jpro's Homepage  Reply with Quote
You may have slightly different settings available in version 8. My screenshot is from version 7.

The normal deviation is the angle that is created as the mesh follows curves. If this number is smaller, the edge length can get larger. sometimes you want the normal deviation to be larger than 12 (maybe even as large a 30) and if you do that, you may need the edge length to be shorter. I have both set a bit toward the small side, since I was just sending you out a general purpose mesh.

You could experiment with 15, 20, and 30 for the breaking angle, and with 0.1, 0.15, and 0.2 for edge length, just to see what changes. My units are inches, and the edge length is 15/100s of an inch. If you are using a metric unit setting, the edge length will require a different value.

Jean
Go to Top of Page

Brett
Inquisitive

New Zealand
53 Posts

Posted - 11/09/2011 :  18:32:50  Show Profile  Reply with Quote
Greatly appreciated. The settings in 8 look the same.

Brett
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
StrataCafe Forums © 2009 StrataCafe Go To Top Of Page
Snitz Forums 2000